Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 01, 2025 - 00:00 AEDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 31, 2025 - 13:31 AEDT
Scheduled
Dear Valued Clients,
Due to an ATO infrastructure upgrade, there will be a temporary outage of electronic lodgments for SMSF annual returns for FY2016 and prior financial years via the Class app, from 1st February to 14th February 2025.
Electronic lodgments for SMSF annual returns for FY2016 and prior years will be available again from 15th February 2025.
Please note that electronic lodgments for SMSF annual returns for FY2017 to FY2024 will not be impacted.
If you have any questions or require further assistance, please feel welcome to reach out to our support team by emailing support@class.com.au, using live chat within the app, or calling us on 1300 851 057.
We appreciate your understanding and continued support.
Best regards,
The Class Team
Posted Jan 31, 2025 - 13:30 AEDT
This scheduled maintenance affected: Class Tax Lodgement - SMSF.